Issues Downloading Reports

Incident Report for Ediphi

Resolved

The earlier issue affecting report downloads has been resolved. For those users that were attempting to download reports:

- If you selected multiple reports to download, you should receive an email with a link shortly.
- If you were trying to download a single report (which downloads from the browser), please retry the download — it should now work as expected.

Thanks again for your patience while we worked through this!
Posted Apr 17, 2025 - 15:34 EDT

Identified

We were notified that some users are experiencing delays or failures when downloading reports. The underlying issue has been identified, and our team is actively working on implementing a fix. We will provide updates as progress continues. Thank you for your patience!
Posted Apr 17, 2025 - 14:26 EDT
This incident affected: Ediphi Platform.